A public message announcement from the PSP Fanboy team: Stop asking if you can downgrade your system. Currently, downgraders only work for PSPs with firmware 2.80 or below. Constantly leaving comments about downgrading from 3.03 will not get responses.

So, what are you supposed to do then? N00bz, "homebrew without a clue," answers some of your burning questions. They note a few key points: there is a "kernel mode exploit" in all PSPs, up to version 3.03, that seems to be unchanged. Once a "user-mode exploit" can be found, it will be theoretically possible to run homebrew on all PSPs--even downgraders should work.

But when will this happen? Who knows. Certainly, there are hard-working homebrew coders trying to find exploits in all of Sony's latest. However, N00bz recommends that if you're ever serious about switching over to homebrew, you should stop upgrading your PSP altogether. 3.04 or whatever future firmware upgrade Sony releases will most likely address these exploits; and it should be much easier to run exploits on 2.81 versus 3.03. There's no guide as to when the homebrew community will release something, but we advise you: please be patient. Personally, I'll keep upgrading to Sony's official firmware because I actually like playing legal games.

[Update 1: Looks like I offended a few of you with my overly bitter comment. I'd like to apologize to those of you that do actually use your homebrew PSPs in a legit manner. As an acknowledgement of the harsh tone I took, I will not delete the comment. Sorry to those that were offended: you are clearly upstanding in an industry where many people take game developers for granted.]

This article was originally published on Joystiq.