Discussion about
dave

July 8th 2014 7:10 pm

Help me fix my weird Foscam networking problem with a router in bridge mode



Recently, I purchased a Foscam FI9821W V2 for both home security and in order to watch my dog while I'm at work (e.g., for those times when he's being a jerk and eating my cherished Dodgers' hat and I need to run home and try and save it: https:­/­/twitter.com­/davely­/status­/4662740908487761...)

Our previous setup consisted of an old laptop, a Logitech C920 webcam and a combination of free apps plus some custom software I wrote that took an image every couple of seconds and displayed it on a simple webpage. Anyway, it worked for the most part -- except when I would forget to plug in power to the laptop, leave the house, and try to check on the dog later only to find that no images had been uploaded in the last few hours. WHAT IS MY DOG UP TO?!

Recently, Amazon had a good deal on some Foscam IP cameras, so I picked up the FI9821W. They shipped the wrong color to me, so while I was waiting for the replacement to come, I set this up on our WiFi network and even got the remote access properly working by setting up port forwarding and all that good stuff.

It's especially nice because when I go to my IP followed by the port (e.g., http://192.168.0.1:123 but using my external IP rather than an internal IP...), I can access all the camera settings (yeah, potential security issues there, but running latest firmware, changed default ports, using a long password, etc).

Anyway, I was pretty happy once it was setup -- though it took a long time to get it right! But hey, now I could check in on the dog any time, either via video or a snapshot uploaded to my simple web interface that I originally used with the C920!

So, fast forward to yesterday! The right color comes in and I disconnect the original camera, get everything all setup. Only this time, I decide to do something different. We're going to connect it directly to a router via ethernet cable. Yes!

Basically, here's the setup:

  1. Internet comes in through Comcast's DOCSIS 3.0 cable modem.
  2. Right next to it is an Airport Extreme for our WiFi fix.
  3. Added a second router hooked up via Cat 6 cable wired through crawlspace to extend WiFi magic into other parts of house and setup in bridge mode!
  4. Foscam FI9821W is wired directly in router 2 (bridge mode).
When I'm at home, I can log into the camera and even get images off it just fine. Once I'm outside my network, I get no response whatsoever. Even though the proper port forwarding is still setup on router 1 (and the Foscam is using the same IP address as the original Foscam I had), I can't connect!

So, I need some help diagnosing this. I read that it has to do with router 2 being setup on bridge mode.

Basically, router 1's IP is something like 10.0.1.1. Router 2 is 10.0.1.2. Even though the Foscam has a dedicated IP (e.g., 10.0.1.3 or whatever), it's unreachable outside my network. I think I read that this has to do with the fact that the second router is in bridge mode. Basically, I guess I have to do some weird trickery and forward requests for a specific port to router 2 instead of my Foscam?

Anyway, what gives? Looking for some helpful advice in trying to figure this out. My dwindling hat collection will thank you. ;)

sort by

13 replies
Dignan17

Hmm. Well, it does seem that much of this has to do with the two-router setup. I don't really know how Apple has decided to make that bridge mode function. When router #2 is in bridge mode, does it have port forwarding options too? I guess that way you could forward from router #1 to router #2 to the Foscam. Ugh, that sounds gross though...

But there's a much simpler solution: a switch. Just get the cheapest switch you can find, then put router #2 and the Foscam on that switch and have the run from router #1 go into the switch instead of router #2. It's not something that should be necessary, but it might save a lot of headache in the long run.
2 like dislike
dave

When the second Airport Extreme router is in bridge mode, all the port forwarding options are disabled. :(

That said, good grief! I was smacking my head against the wall all evening trying to figure this out. A switch. So brilliantly simple and obvious. I'll try this tonight. I think I even have a spare in the basement!
1 like dislike
frankspin

So I'm going to jump in here and say that you should not need the switch, I ran a similar set up because FiOS requires me to use their hardware.

Make sure the second router/AP is set to bridge mode and DHCP is disabled on it. It should not be handing out DHCP addresses at all, that should come from the main router. If it's disabled the port forwarding should be done on the main router, and that should get you working.

HOWEVER, it is entirely possible this getting double NAT'd and that will cause your issue.

But I agree, a switch would simplify this ten fold. Router -> switch <- foscam and AP/Router
1 like dislike
Dignan17

Happy to help! Yeah, technically you shouldn't have to use one because I would think that router #2 would make the LAN ports nothing more than a dumb switch, but I haven't messed with Airports in a while, so I don't know what's going on in there.
0 like dislike
dave

Yeah, technically you shouldn't have to use one because I would think that router #2 would make the LAN ports nothing more than a dumb switch...

Agreed -- that's what I expected to happen but I have no idea what's going on with Apple's wacky setup. It's supposed to just work, right? ;)

Anyway, the switch idea worked perfectly!!! I can now see the camera again from inside the network, outside the network, and whatever else. Like I said, no idea what's going on with the Apple routers (as Frank mentioned, I'm probably being double NAT'd or some crazy thing).

So, updating my ridiculous network image, the network now looks like this and things are working peachy keen. Thanks for you help, everyone!

1 like dislike
Dignan17

Excellent! BTW, what are you using to make those graphics?
0 like dislike
frankspin

I, for one, only acknowledge network maps made in Visio.
1 like dislike
dave

I'm using Pixelmator. It's a Photoshop style app for OS X, but much cheaper than the real thing (not a realy replacement, but it comes in handy).
0 like dislike
gRagib

Just to be on the safe side, I'd plug a computer into ROUTER 2 using ethernet cable to confirm that the gateway is ROUTER 1. If the gateway is ROUTER 2 (don't know why that should be true, but who knows?), that could explain the problem.
1 like dislike
dave

Yeah, this works fine! There's something mysterious happening here. It looks like putting a switch in between the routers and hooking the camera up to that is the way to go.
0 like dislike
Dignan17

BTW, so you're liking those Foscams? I have one of those and one Hikvision. The Hikvision beats it hands down for video quality, but the Foscam wins on every other front, from flexibility (wired and wireless), price, and features (SD card, pan/tilt). I'm really impressed by what they've done for the price.
1 like dislike
dave

I'm mostly enjoying it! :)

I'll do a better write up explaining my experiences soon. I am having fun with it though and I do like the flexibility of being able to do what I want with the data that's captured.
0 like dislike
groovechicken

There is no reason this should not work. As long as all the networking equipment is on the same subnet, everything on the local network should be talking to each other. If external access was working with the 1st camera but not the 2nd, either the ARP tables in the main Airport are still looking for the MAC of the old camera, or you made a mistake on the setting in the camera for Gateway or Subnet... or the camera is squirrelly. If the ARP tables are messed up, rebooting all the Airports should clear that up. Did you check for a firmware update?

I agree with Dignan17 that the next testing step would be to try putting a switch in the chain to see what happens. I will really be surprised if that solves it, though. I am pretty sure that the ports in the Airport are just a basic switch because I am almost certain I have used one temporarily as a switch before where I know the Airport was configured with a different subnet than what I was using on the stuff connected to the ports.

Also, you need to check to be sure Comcast isn't filtering the ports that camera uses. Most ISPs are filtering at least some ports.
1 like dislike
share:

5 users following this discussion:

  • Dignan17
  • gRagib
  • groovechicken
  • frankspin
  • dave

This discussion has been viewed 1262 times.
Last activity .