Discussion about
CoBullet

August 6th 2014 11:21 am

Writing a product review

So, basically I bought an Acer Aspire S7-392 and I was looking at all the reviews on the internet and it seems like absolutely nobody talks about how bad the design of the power cable is. So I was going to write a review and well, every time I press the "Write a review" button on the webpage, literally nothing happens. Have tried it in Chrome, Incognito Chrome, and in Internet Explorer. Also have tried going to just the "Write a review" webpage located here, www.engadget.com­/post­/­#review, and a list is never populated. When searching you are also given no options of what to choose from.

Help?

sort by

7 replies
CoBullet

Never mind, realized that you have to mark it as "Have it" or "Had it". What a silly design, very confusing to newcomers and you are left with no warning as to why you can't write a review...

I would suggest fixing that..
1 like dislike
TgD

Weird. On that link you posted, it says

"Start by choosing a product from your have or had list..."

and slightly further down it says

"Need to add a product to your list first? find it here" with a search box.

Here is what I see... seems pretty self explanatory... unless you see something different

1 like dislike
CoBullet

Here is what I see, and this was 2-3 minutes of waiting after I had typed in "Acer ASpire S7". Also if you notice, there is no "Have" or "Had" that has been updated for me, yet I have "Acer Aspire S7 392" as my had and "Lenovo Yoga 2" as my have.

0 like dislike
TgD

Looks like a bug to me if its not detecting your typing! I do see the products you mentioned in your screenshot under "already reviewed" though.
0 like dislike
frankspin

The screen is displaying the items based on what is currently on your have/had/want lists. So if CoBullet has nothing on their list, nothing is going to show up.
0 like dislike
frankspin

I apologize for the issue and will be passing your feedback along to the product team.
0 like dislike
TommyIs

Same here. When I try to ask a question, it opens a new page, but not logged in. So, I try to log in and it won't let me. I go back several pages, and I'm still logged in. I try again and again it takes me to a page where I'm not logged in. Essentially, I can't log in and I can't ask a question. This site sucks. I'm out of here.
0 like dislike
share:

6 users following this discussion:

  • dave
  • frankspin
  • CoBullet
  • TgD
  • johnalica
  • TommyIs

This discussion has been viewed 1419 times.
Last activity .