Question about
adma84

Speakerphone/Microphone Disabled

My pre has an issue that, after some googling, doesn't seem all that unique. Apparently, it thinks my headset is plugged in (despite the fact that it is not). This means that I can use speakerphone and bluetooth, but not the built in microphone or earpiece. Anyone here noticed it or have a decent fix?

sort by

5 answers
shawalli

I'm having the same issue with mine; alot of people are proposing that it's somehow related to pandora and listening to it with headphones plugged in. I made sure my speakerphone was working (swiping and listening for the whoosh sound) and then turned on pandora. There was no sound coming out of the phone; when i plugged headphones in, however, there was sound.
mark as good answer

0 people like this answer

shawalli

does anyone have a webOS image who could look through the code and possibly find the snippet that controls the headphones or the speaker being enabled?
mark as good answer

0 people like this answer

shawalli

here with an update (reposting this from my message on palms forums)

SOLUTION: Alright guys, found (correction, my helpful brother found) a solution to the problem. I got the Pre on June 6th and had this problem about a week later. I returned the pone and got another one. For hardware reasons, I had to get another phone after that. Long story short, after having the replacement for about a week, the speaker and mic cut out on this phone too.



We've began researching this for a few days and pretty much decided it was a software problem, and may or not not have been caused by Pandora. The general online concensus is that the phone continues to think that the phone is in headphones mode (either from pandora or just plugigng the headphones in[idk if third party headphones play a part or not]). Im not sure where the post came from, so if you wrote it originally, feel free to take credit:



" I've posted this on another thread but figured I'd post here as well. I've been having the same issue (in which the phone app is still showing a headset icon in the bottom left). The above instructions didn't work but I figured out another fix. in the phone app I called my voicemail with my headset connected, then clicked Mute and unplugged the headset. It immediatly started working as advertised. Then just to test I went into the Music app and Pandora and they worked fine as well. Hope this helps"



IT WORKED. Immediately after trying this I got sound back form the speaker (and the mic worked), after having to use bluetooth for almost a week.
mark as good answer

0 people like this answer

Jedinate

I have this issue too, it just started last night. I've tried the fix posted above as well as about 10 others, NOTHING is working.

I don't think it's a Pandora issue, since I haven't used Pandora or my media player in a week, this happened after a call. I've unplugged/plugged in hundreds of times, tried the mute thing, tried a reset and it's still no good.

Does anyone have confirmation from Palm that it is a software issue? I would hate to return my phone if an update will fix this.
mark as good answer

0 people like this answer

Jedinate

Mine suddenly started working again, after taking a call earlier tonight. I didn't do anything special other than pull out the jack as the call ended.
mark as good answer

0 people like this answer

share:

Products mentioned

3 users following this question:

  • shawalli
  • Jedinate
  • adma84

This question has been viewed 1280 times.
Last activity .