Post Thumbnail

Gee, quite a day for Apple software updates. Apple has put out an update to Safari beta 4, and the Leopard version requires OS X 10.5.7 which was just released today. There is also a version for Tiger that requires OS X 10.4.11 and security update 2009-002. Here is a download link. As is often the c...

5 years ago 0 Comments
May 12, 2009 at 8:30PM