Post Thumbnail

If you're about to buy the new PSOne Classics release Pocket Fighter to enjoy on the go, wait! Reader Letters2Kay found out that, unlike every other PSOne Classics release (as far as we know), Pocket Fighter is only compatible with PS3. A PlayStation Blog commenter also pointed out the restriction,...

February 10th 2011 at 2:00am 0 Comments