Post Thumbnail

Apparently patch 2.0.5 came out overnight last night or early this morning. A lot of users are getting an "Unable to validate game version" error (pictured above) along with a myriad of other connection problems. The official forums are also down, or so slow as to be effectively down. I'm going to ...

8 years ago 0 Comments
January 14, 2007 at 10:25AM