PwnageTool and QuickPwn for 2.1 iPhone's released

For iPhone owners who want the benefit of the 2.1 firmware, but also want to run their jail-broken applications, the iPhone Dev Team has just released PwnageTool and QuickPwn for 2.1 devices. Please note: this does NOT work with the new iPod Touch 2g and is for iPhones or first generation Touch devices only.

The Dev Team managed to work around iTunes 8 without having to patch the program, so pwners can try the new tool without worrying about altering a core OS X program.

Let us know in the comments how well Pwnage and/or Quick/Pwn is working with your device. As always, pwning is unauthorized, do it at your own risk and make sure you back-up any important information before using the tool.

Thanks to everyone who sent this in!
This article was originally published on Tuaw.