Post Thumbnail

Xbox SmartGlass has migrated over to Amazon's Kindle Fire and Kindle Fire HD tablets. First generation Kindle Fires are out of luck since they're based on Android version 2.3 and the Xbox SmartGlass app requires Android 4.0 and higher.An update to Xbox SmartGlass little over a week ago made Microso...

April 23rd 2013 at 1:00am 0 Comments