Post Thumbnail

Let's take a look at what addons are working for patch 3.0.2. First a simple rule taken from the UI forums post done by Kaydeethree: "Any 'Wrath beta' compatible mod will work in 3.0.2." With that said, there is a long and comprehensive listing of 3.0.2 compatible addons over on WoWWiki. But the ...

6 years ago 0 Comments
October 14, 2008 at 2:20AM