Post Thumbnail

We got a brief glimpse of Google's body browser at the Chrome event earlier this month, and wouldn't ya know it, the violation of privacy simulator / learning tool is hanging out in Google labs. A browser with WebGL support is required, which means Firefox 4 and Chrome 9 betas (or Chrome 8 if you e

4 years ago 0 Comments
December 20, 2010 at 4:16PM