Post Thumbnail

Not feeling hot about the trouble-prone iPhone 4, but still tempted by its optional iMovie app? Now you have a choice! Turns out to run said app on other devices (including iPod touch, supposedly) running iOS 3.0 and above, all you need are a jailbroken iOS device, iMovie for iPhone from the App St

4 years ago 0 Comments
June 30, 2010 at 12:21PM